Table of contents
Property Validation
Download API definition:
This operation is deprecated. Please upgrade to the current version of this API as soon as possible.
GET https://api.bentley.com/validation/propertyValue/ruletemplates?projectId[&continuationToken][&$top]

Retrieves a list of property value validation rule templates for the project specified by the project id.

Authentication

Requires Authorization header with valid Bearer token for scope itwin-platform.

For more documentation on authorization and how to get access token visit OAUTH2 Authorization page.

Request parameters

Name
In
Required?
Description
projectId
query
Yes

The id of the project associated with the rule templates.

continuationToken
query
No

Parameter that enables continuing to the next page of the previous paged query. This must be passed exactly as it is in the response body's _links.next property. If this is specified and $top is omitted, the next page will be the same size as the previous page.

$top
query
No

The number of rule templates to get in each page. Max 50, but 15 is the default if this parameter is not included.

Request headers

Name
Required?
Description
Authorization
Yes

OAuth access token with itwin-platform scope

Accept
Yes

Setting to application/vnd.bentley.itwin-platform.v1+json is recommended.

Response 200 OK

OK

json
{
    "ruleTemplates": [{
        "id": "ZuO3OCC8sUuVcgeXz1Ih_dLm3ASFdg1An09aEm68J-k",
        "displayName": "PropertyValueAtMost",
        "description": "Checks if the property has numeric elements less than or equal to upper bound",
        "prompt": "Checks the value of numeric elements to maximum of given value",
        "templateExpression": {
            "propertyName": "Pitch",
            "upperBound": "10"
        }
    }],
    "_links": {
        "next": {
            "href": "https://api.bentley.com/validation/propertyValue/ruleTemplates?projectId=38b7e366-bc20-4bb1-9572-0797cf5221fd&continuationToken=eyJ0b3AiOjQsInNraXBUb2tlbiI6Ik1nPT0ifQ"
        }
    }
}

Response 401 Unauthorized

This response indicates that request lacks valid authentication credentials. Access token might not been provided, issued by the wrong issuer, does not have required scopes or request headers were malformed.

json
{
    "error": {
        "code": "HeaderNotFound",
        "message": "Header Authorization was not found in the request. Access denied."
    }
}

Response 404 Not Found

This response indicates that the specified project was not found.

json
{
    "error": {
        "code": "ProjectNotFound",
        "message": "Requested project is not available."
    }
}

Response 429 Too many requests

This response indicates that the user has sent too many requests in a given amount of time.

json
{
    "error": {
        "code": "TooManyRequests",
        "message": "More requests were received than the subscription rate-limit allows."
    }
}

Response headers

Name
Description
retry-after

The number of requests exceeds the rate-limit for the client subscription.

Property Value Templates

Array of property value validation rule templates

TableSchema
Name
Type
Description

Property Value Rule Template

TableSchema
Name
Type
Description
id
String

The id of the rule template.

displayName
String

The display name of the rule template.

description
String

The description of the rule template.

prompt
String

The prompt of the rule template.

templateExpression
Object

The rule template expression.

Link

Hyperlink container.

TableSchema
Name
Type
Description
href
String

Hyperlink container.

Forward-Only Paging Link

Link to get the next page of data, if applicable. Link to the previous page is not available.

TableSchema
Name
Type
Description
next

Error

Contains error information.

TableSchema
Name
Type
Description
code
String

One of a server-defined set of error codes.

message
String

A human-readable representation of the error.

target
String

The target of the error.

Error Response

Gives details for an error that occurred while handling the request. Note that clients MUST NOT assume that every failed request will produce an object of this schema, or that all of the properties in the response will be non-null, as the error may have prevented this response from being constructed.

TableSchema
Name
Type
Description
error

Error information.