Table of contents
Property Validation
Download API definition:
This operation is deprecated. Please upgrade to the current version of this API as soon as possible.
POST https://api.bentley.com/validation/propertyValue/rules

Creates a property value validation rule for the specified criteria and returns the rule id.

Authentication

Requires Authorization header with valid Bearer token for scope itwin-platform.

For more documentation on authorization and how to get access token visit OAUTH2 Authorization page.

Request headers

Name
Required?
Description
Authorization
Yes

OAuth access token with itwin-platform scope

Accept
Yes

Setting to application/vnd.bentley.itwin-platform.v1+json is recommended.

Request body

Create Property Value Rule

Name
Type
Required?
Description
displayName
String
Yes

The name of the rule.

description
String
Yes

The description of the rule.

templateId
String
Yes

The template id of the rule.

ecSchema
String
Yes

The EC schema of the rule.

ecClass
String
Yes

The EC class of the rule.

whereClause
String,null
No

The where clause of the rule.

functionParameters
Object
Yes

The function parameters for the rule.

severity
String
Yes

The severity of the rule. One of 'veryHigh', 'high', 'medium', 'low'

dataType
String
Yes

The data type of the rule. One of 'property', 'aspect', 'typeDefinition'

Example

json
{
    "displayName": "TestRule1",
    "description": "test rule",
    "templateId": "ZuO3OCC8sUuVcgeXz1Ih_fFWlDoxH2FNmf0lWD6M8Dg",
    "severity": "high",
    "ecSchema": "ArchitecturalPhysical",
    "ecClass": "Door",
    "whereClause": "Roll = '10'",
    "dataType": "property",
    "functionParameters": {
        "propertyName": "Pitch",
        "lowerBound": "1",
        "upperBound": "2"
    }
}

Response 201 Created

Created

json
{
    "rule": {
        "id": "ZuO3OCC8sUuVcgeXz1Ih_cAGbqvuxsVHuHltkUef4O4",
        "displayName": "PV-rule-2",
        "description": "PV rule 2",
        "templateId": "ZuO3OCC8sUuVcgeXz1Ih_fFWlDoxH2FNmf0lWD6M8Dg",
        "severity": "medium",
        "ecSchema": "ArchitecturalPhysical",
        "ecClass": "Door",
        "whereClause": null,
        "functionParameters": {
            "propertyName": "Pitch",
            "lowerBound": "1",
            "upperBound": "2"
        },
        "dataType": "property",
        "_links": {
            "self": {
                "href": "https://api.bentley.com/validation/propertyValue/rules/ZuO3OCC8sUuVcgeXz1Ih_cAGbqvuxsVHuHltkUef4O4"
            },
            "createdBy": {
                "href": "https://api.bentley.com/accesscontrol/itwins/38b7e366-bc20-4bb1-9572-0797cf5221fd/members/99cf5e21-735c-4598-99eb-fe3940f96353"
            }
        }
    }
}

Response 401 Unauthorized

This response indicates that request lacks valid authentication credentials. Access token might not been provided, issued by the wrong issuer, does not have required scopes or request headers were malformed.

json
{
    "error": {
        "code": "HeaderNotFound",
        "message": "Header Authorization was not found in the request. Access denied."
    }
}

Response 422 Unprocessable Entity

The 422 (Unprocessable Entity) status code indicates that the request cannot be processed by the server due to a client error (e.g. malformed request syntax)

json
{
    "error": {
        "code": "InvalidValidationRequest",
        "message": "Invalid property value validation request.",
        "details": [{
                "code": "InvalidRequestBody",
                "message": "Required property 'displayName' is missing in the request body.",
                "target": "displayName"
            },
            {
                "code": "InvalidRequestBody",
                "message": "Required property 'description' is missing in the request body.",
                "target": "description"
            },
            {
                "code": "InvalidRequestBody",
                "message": "Required property 'templateId' is missing in the request body.",
                "target": "templateId"
            },
            {
                "code": "InvalidRequestBody",
                "message": "Required property 'severity' is missing in the request body.",
                "target": "severity"
            },
            {
                "code": "InvalidRequestBody",
                "message": "Required property 'dataType' is missing in the request body.",
                "target": "dataType"
            },
            {
                "code": "InvalidRequestBody",
                "message": "Required property 'ecSchema' is missing in the request body.",
                "target": "ecSchema"
            },
            {
                "code": "InvalidRequestBody",
                "message": "Required property 'ecClass' is missing in the request body.",
                "target": "ecClass"
            },
            {
                "code": "InvalidRequestBody",
                "message": "Required property 'functionParameters' is missing in the request body.",
                "target": "functionParameters"
            },
            {
                "code": "InvalidRequestBody",
                "message": "The request is invalid."
            },
            {
                "code": "InvalidRequestBody",
                "message": "Request body was not provided."
            },
            {
                "code": "InvalidRequestBody",
                "message": "The request body is not a valid JSON object."
            }
        ]
    }
}

Response 429 Too many requests

This response indicates that the user has sent too many requests in a given amount of time.

json
{
    "error": {
        "code": "TooManyRequests",
        "message": "More requests were received than the subscription rate-limit allows."
    }
}

Response headers

Name
Description
retry-after

The number of requests exceeds the rate-limit for the client subscription.

Property Value Rule

TableSchema
Name
Type
Description
id
String

The id of the rule.

displayName
String

The display name of the rule.

description
String

The description of the rule.

templateId
String

The template id of the rule.

creationDateTime
Date-time

The date/time when the rule was created.

modificationDateTime
Date-time

The date/time when the rule was last modified.

ecSchema
String

The EC schema of the rule.

ecClass
String

The EC class of the rule.

whereClause
String,null

The where clause of the rule.

functionName
String

The function name of the rule.

functionParameters
Object

The function parameters for the rule.

severity
String

The severity of the rule. One of 'veryHigh', 'high', 'medium', 'low'

dataType
String

The data type of the rule. One of 'property', 'aspect', 'typeDefinition'

_links

The link to get the rule details.

Property Value Rule Link

TableSchema
Name
Type
Description
self

The link to get the rule details.

Create Property Value Rule

Specify the rule criteria to create a property value validation rule.

TableSchema
Name
Type
Description
displayName
String

The name of the rule.

description
String

The description of the rule.

templateId
String

The template id of the rule.

ecSchema
String

The EC schema of the rule.

ecClass
String

The EC class of the rule.

whereClause
String,null

The where clause of the rule.

functionParameters
Object

The function parameters for the rule.

severity
String

The severity of the rule. One of 'veryHigh', 'high', 'medium', 'low'

dataType
String

The data type of the rule. One of 'property', 'aspect', 'typeDefinition'

Link

Hyperlink container.

TableSchema
Name
Type
Description
href
String

Hyperlink container.

Error

Contains error information.

TableSchema
Name
Type
Description
code
String

One of a server-defined set of error codes.

message
String

A human-readable representation of the error.

target
String

The target of the error.

Error Response

Gives details for an error that occurred while handling the request. Note that clients MUST NOT assume that every failed request will produce an object of this schema, or that all of the properties in the response will be non-null, as the error may have prevented this response from being constructed.

TableSchema
Name
Type
Description
error

Error information.