Reality Data
Creates a reality data.
As shown in the request section below, you must provide a request body.
You MUST provide the displayName
, classification
and type
properties.
Valid values for the classification
property are: Terrain
, Imagery
, Pinned
, Model
, Undefined
. For more details on each value, see Reality Data Properties in documentation.
We recommend specifying a projectId
in the request body, as it is used to choose the data center where the reality data is stored (the same as the project). If no projectId
can be provided, the default data center of the organization is selected.
After creation, the reality data will be associated to the specified project.
Authentication
Requires Authorization
header with valid Bearer token for scope realitydata:modify
.
For more documentation on authorization and how to get access token visit OAUTH2 Authorization page.
Authorization
User must be an Organization Administrator for the Organization that owns a given Project or have {permission}
permission assigned at the Project level.
An Organization Administrator must have at least one of the following roles assigned in User Management: Account Administrator, Co-Administrator, or CONNECT Services Administrator. For more information about User Management please visit our Bentley Communities Licensing, Cloud, and Web Services wiki page.
Rate limits
All iTwin Platform API operations have a rate limit. For more documentation on that visit Rate limits and quotas page.