Table of contents
PnID to iTwin
Download API definition:
GET https://api.bentley.com/synchronization/pnidtoitwin/inferences?iTwinId[&$top][&$continuationToken]

Returns all PnID Inferences in iTwin.

Authentication

Requires Authorization header with valid Bearer token for scope synchronization:read.

For more documentation on authorization and how to get access token visit OAUTH2 Authorization page.

Request parameters

Name
In
Required?
Description
iTwinId
query
Yes

Id of the iTwin that created the PnID Inference.

$top
query
No

Optional max items to be sent in response.

$continuationToken
query
No

Optional token to retrieve next page in paginated response.

Request headers

Name
Required?
Description
Authorization
Yes

OAuth access token with scope synchronization:read

Accept
No

Setting to application/vnd.bentley.itwin-platform.v2+json is required.

Response 200 OK

List of PnID Inference returned successfully.

json
{
    "inferences": [{
        "id": "bcbc71d4-c4d8-4cf7-b1fe-aaa194cd61c3",
        "modelVersion": "1.3",
        "lastModifiedDateTime": "2022-01-20T14:45:47.073Z",
        "createdDateTime": "2022-01-20T14:45:47.073Z",
        "_links": {
            "iTwin": {
                "href": "https://api.bentley.com/itwins/ea9cb5ab-22c5-4cef-807a-df47f07b01f3"
            },
            "run": {
                "href": "https://api.bentley.com/synchronization/pnidtoitwin/inferences/bcbc71d4-c4d8-4cf7-b1fe-aaa194cd61c3/run"
            },
            "inputs": {
                "href": "https://api.bentley.com/synchronization/pnidtoitwin/inferences/bcbc71d4-c4d8-4cf7-b1fe-aaa194cd61c3/inputs"
            },
            "results": {
                "href": "https://api.bentley.com/synchronization/pnidtoitwin/inferences/bcbc71d4-c4d8-4cf7-b1fe-aaa194cd61c3/run/results"
            }
        }
    }],
    "_links": {
        "next": {
            "href": "https://api.bentley.com/synchronization/pnidtoitwin/inferences?iTwinId=ea9cb5ab-22c5-4cef-807a-df47f07b01f3&$top=100&$continuationToken=eyJOZXh0UGFydGl0aW9uS2V5IjoiMSExMDAhT0RnMll6TmlOMlF0TnpNM1pDMDBOakUwTFRsaE4yTXROV1JsTlRobE5qTm1OVGc0WHpBNFlqZzROVEV3TFdNek1tTXRORGt4WWkwNVpqZGhMVEZpTXpBd016azFPV1F6TlEtLSIsIk5leHRSb3dLZXkiOiIxASD4IU56Y3dNREU1T1RFdFl6UmpZeSAbTUdKaUxUa3dOMlV0WXpPrewtSmhZV0k0WlRBMSIsIk5leHRUYWJsZU5hbWUiOm51bGwsIlLncmdldExvY2F0aW9uIjowfQ--"
        },
        "self": {
            "href": "https://api.bentley.com/synchronization/pnidtoitwin/inferences?iTwinId=ea9cb5ab-22c5-4cef-807a-df47f07b01f3&$top=100"
        }
    }
}

Response 401 Unauthorized

This response indicates that request lacks valid authentication credentials. Access token might not been provided, issued by the wrong issuer, does not have required scopes or request headers were malformed.

json
{
    "error": {
        "code": "HeaderNotFound",
        "message": "Header Authorization was not found in the request. Access denied."
    }
}

Response 422 Unprocessable Entity

The 422 (Unprocessable Entity) status code indicates that the request cannot be processed by the server due to a client error (e.g. malformed request syntax).

json
{
    "error": {
        "code": "InvalidPnIDtoiTwinRequest",
        "message": "Cannot get requested resource.",
        "details": [{
            "code": "InvalidProperty",
            "message": "Required properties are not provided or incorrect.",
            "target": "$top"
        }]
    }
}

Response 429 Too many requests

This response indicates that the user has sent too many requests in a given amount of time.

json
{
    "error": {
        "code": "TooManyRequests",
        "message": "More requests were received than the subscription rate-limit allows."
    }
}

Response headers

Name
Description
retry-after

The number of requests exceeds the rate-limit for the client subscription.

Link

Hyperlink container.

TableSchema
Name
Type
Description
href
String

Hyperlink to the specific entity.

PnID Inference

PnID Inference details.

TableSchema
Name
Type
Description
id
String

Unique PnID Inference identifier.

modelVersion
String

ML Model version for PnID Inference.

lastModifiedDateTime
Date-time

Date time of last PnID Inference modification.

createdDateTime
Date-time

Date time of PnID Inference creation.

_links

Contains the hyperlinks to related data of PnID Inference.

PnIDInferenceLinks

TableSchema
Name
Type
Description
iTwin

Information about iTwin.

run

Information about all inference run.

inputs

Information about all inference inputs.

results

Information about all inference results.

Paging Links

URLs for redoing the current request or getting the next page of results if applicable.

TableSchema
Name
Type
Description
self

URL for repeating the current request.

next

URL for getting the next page of results.

PnID Inference Page

List of PnID Inferences.

TableSchema
Name
Type
Description
inferences

Container for PnID Inferences.

_links

URLs for redoing the current request or getting next page of results, if applicable.

Error

Contains error information.

TableSchema
Name
Type
Description
code
String

One of a server-defined set of error codes.

message
String

A human-readable representation of the error.

target
String

The target of the error.

Error Response

Gives details for an error that occurred while handling the request. Note that clients MUST NOT assume that every failed request will produce an object of this schema, or that all of the properties in the response will be non-null, as the error may have prevented this response from being constructed.

TableSchema
Name
Type
Description
error

Error information.