Table of contents
PnID to iTwin
Download API definition:
GET https://api.bentley.com/synchronization/pnidtoitwin/inferences/{inferenceId}/run

Returns status of PnID Inference Run.

Authentication

Requires Authorization header with valid Bearer token for scope synchronization:read.

For more documentation on authorization and how to get access token visit OAUTH2 Authorization page.

Request parameters

Name
In
Required?
Description
inferenceId
template
Yes

Id of the created PnID Inference.

Request headers

Name
Required?
Description
Authorization
Yes

OAuth access token with scope synchronization:read

Accept
No

Setting to application/vnd.bentley.itwin-platform.v2+json is required.

Response 200 OK

PnID Inference Run result returned successfully.

json
{
    "run": {
        "status": "inProgress",
        "duration": "PT10M",
        "progress": 0.1,
        "createdDateTime": "2022-01-20T14:45:47.073Z",
        "_links": {
            "inputs": {
                "href": "https://api.bentley.com/synchronization/pnidtoitwin/inferences/bcbc71d4-c4d8-4cf7-b1fe-aaa194cd61c3/inputs"
            },
            "results": {
                "href": "https://api.bentley.com/synchronization/pnidtoitwin/inferences/bcbc71d4-c4d8-4cf7-b1fe-aaa194cd61c3/results"
            },
            "inference": {
                "href": "https://api.bentley.com/synchronization/pnidtoitwin/inferences/bcbc71d4-c4d8-4cf7-b1fe-aaa194cd61c3"
            }
        }
    }
}

Response 401 Unauthorized

This response indicates that request lacks valid authentication credentials. Access token might not been provided, issued by the wrong issuer, does not have required scopes or request headers were malformed.

json
{
    "error": {
        "code": "HeaderNotFound",
        "message": "Header Authorization was not found in the request. Access denied."
    }
}

Response 404 Not Found

Specified Inference Run was not found.

json
{
    "error": {
        "code": "PnIDInferenceNotFound",
        "message": "Requested PnID Inference is not available."
    }
}

Response 429 Too many requests

This response indicates that the user has sent too many requests in a given amount of time.

json
{
    "error": {
        "code": "TooManyRequests",
        "message": "More requests were received than the subscription rate-limit allows."
    }
}

Response headers

Name
Description
retry-after

The number of requests exceeds the rate-limit for the client subscription.

Link

Hyperlink container.

TableSchema
Name
Type
Description
href
String

Hyperlink to the specific entity.

PnID Inference Run Result

Container for PnID Inference Run.

TableSchema
Name
Type
Description
run

PnID Inference Run properties.

PnID Inference Run Status

Indicates state of the PnID Inference Run.

TableSchema
Name
Type
Description
No data.

PnID Inference Run

PnID Inference Run details.

TableSchema
Name
Type
Description
duration
Duration

Computation duration of PnID Inference Run.

progress
Double

PnID Inference Run progress from 0 (no progress) to 1 (completed).

createdDateTime
Date-time

Date time of PnID Inference Run creation.

_links

Contains the hyperlinks to the related data of the PnID Inference Run.

PnID Inference Run Links

Contains the hyperlinks to related data of inference run.

TableSchema
Name
Type
Description
inputs

Information about all inference inputs.

results

Information about all inference results.

inference

Information about all inference.

Error

Contains error information.

TableSchema
Name
Type
Description
code
String

One of a server-defined set of error codes.

message
String

A human-readable representation of the error.

target
String

The target of the error.

Error Response

Gives details for an error that occurred while handling the request. Note that clients MUST NOT assume that every failed request will produce an object of this schema, or that all of the properties in the response will be non-null, as the error may have prevented this response from being constructed.

TableSchema
Name
Type
Description
error

Error information.