Table of contents
PnID to iTwin
Download API definition:
GET https://api.bentley.com/synchronization/pnidtoitwin/inferences/{inferenceId}/run/results

Returns all PnID Inference Results.

Authentication

Requires Authorization header with valid Bearer token for scope synchronization:read.

For more documentation on authorization and how to get access token visit OAUTH2 Authorization page.

Request parameters

Name
In
Required?
Description
inferenceId
template
Yes

Id of the created PnID Inference.

Request headers

Name
Required?
Description
Authorization
Yes

OAuth access token with scope synchronization:read

Accept
No

Setting to application/vnd.bentley.itwin-platform.v2+json is required.

Response 200 OK

List of PnID Inference Run results returned successfully.

json
{
    "results": [{
        "id": "cG5pZF9wZGZfcDAwMDAxLmpzb24-",
        "filename": "pnid_pdf_p00001.json",
        "size": 100,
        "_links": {
            "content": {
                "href": "https://api.bentley.com/synchronization/pnidtoitwin/inferences/bcbc71d4-c4d8-4cf7-b1fe-aaa194cd61c3/run/results/cG5pZF9wZGZfcDAwMDAxLmpzb24-/content"
            }
        }
    }],
    "_links": {
        "self": {
            "href": "https://api.bentley.com/synchronization/pnidtoitwin/inferences/bcbc71d4-c4d8-4cf7-b1fe-aaa194cd61c3/run/results"
        },
        "inference": {
            "href": "https://api.bentley.com/synchronization/pnidtoitwin/inferences/bcbc71d4-c4d8-4cf7-b1fe-aaa194cd61c3"
        }
    }
}

Response 401 Unauthorized

This response indicates that request lacks valid authentication credentials. Access token might not been provided, issued by the wrong issuer, does not have required scopes or request headers were malformed.

json
{
    "error": {
        "code": "HeaderNotFound",
        "message": "Header Authorization was not found in the request. Access denied."
    }
}

Response 404 Not Found

Specified Inference was not found.

json
{
    "error": {
        "code": "PnIDInferenceNotFound",
        "message": "Requested PnID Inference is not available."
    }
}

Response 429 Too many requests

This response indicates that the user has sent too many requests in a given amount of time.

json
{
    "error": {
        "code": "TooManyRequests",
        "message": "More requests were received than the subscription rate-limit allows."
    }
}

Response headers

Name
Description
retry-after

The number of requests exceeds the rate-limit for the client subscription.

Link

Hyperlink container.

TableSchema
Name
Type
Description
href
String

Hyperlink to the specific entity.

PnID Inference Input Links

Contains the hyperlinks to related data of PnID Inference Inputs.

TableSchema
Name
Type
Description
content

Information about uploaded input content.

PnID Inference Run Result

Represents result file for PnID Inference Run.

TableSchema
Name
Type
Description
id
String

File Id of PnID Inference Run Result

filename
String

Filename of PnID Inference Run Result.

size
Int64

File size of PnID Inference Run Result.

Paging Links with inference link

URL for getting inference.

TableSchema
Name
Type
Description
self

URL for getting the previous page of results.

inference

URL for getting inference

PnID Inference Run Result Page

List of PnID Inference Run Results.

TableSchema
Name
Type
Description
results

Container for PnID Inference Run Results.

_links

URL for getting inference.

Error

Contains error information.

TableSchema
Name
Type
Description
code
String

One of a server-defined set of error codes.

message
String

A human-readable representation of the error.

target
String

The target of the error.

Error Response

Gives details for an error that occurred while handling the request. Note that clients MUST NOT assume that every failed request will produce an object of this schema, or that all of the properties in the response will be non-null, as the error may have prevented this response from being constructed.

TableSchema
Name
Type
Description
error

Error information.