Table of contents
PnID to iTwin
Download API definition:
GET https://api.bentley.com/synchronization/pnidtoitwin/inferences/{inferenceId}/inputs/{fileId}/content

Returns content of PnID Inference Input.

Authentication

Requires Authorization header with valid Bearer token for scope synchronization:read.

For more documentation on authorization and how to get access token visit OAUTH2 Authorization page.

Request parameters

Name
In
Required?
Description
inferenceId
template
Yes

Id of the created PnID Inference.

fileId
template
Yes

Id of the file uploaded to PnID Inference.

Request headers

Name
Required?
Description
Authorization
Yes

OAuth access token with scope synchronization:read

Accept
No

Setting to application/vnd.bentley.itwin-platform.v2+json is required.

Response 200 OK

Content of the inference input file returned successfully.

Response 401 Unauthorized

This response indicates that request lacks valid authentication credentials. Access token might not been provided, issued by the wrong issuer, does not have required scopes or request headers were malformed.

json
{
    "error": {
        "code": "HeaderNotFound",
        "message": "Header Authorization was not found in the request. Access denied."
    }
}

Response 404 Not Found

Specified Inference Input was not found.

json
{
    "error": {
        "code": "PnIDInferenceInputFileNotFound",
        "message": "Requested PnID Inference Input is not available."
    }
}

Response 429 Too many requests

This response indicates that the user has sent too many requests in a given amount of time.

json
{
    "error": {
        "code": "TooManyRequests",
        "message": "More requests were received than the subscription rate-limit allows."
    }
}

Response headers

Name
Description
retry-after

The number of requests exceeds the rate-limit for the client subscription.

File Content

Content of the input/result file.

TableSchema
Name
Type
Description
No data.

Error

Contains error information.

TableSchema
Name
Type
Description
code
String

One of a server-defined set of error codes.

message
String

A human-readable representation of the error.

target
String

The target of the error.

Error Response

Gives details for an error that occurred while handling the request. Note that clients MUST NOT assume that every failed request will produce an object of this schema, or that all of the properties in the response will be non-null, as the error may have prevented this response from being constructed.

TableSchema
Name
Type
Description
error

Error information.