Table of contents
Clash Detection
Download API definition:
This API is deprecated. Please upgrade to the current version of this API as soon as possible.
This operation is deprecated. Please upgrade to the current version of this API as soon as possible.
GET https://api.bentley.com/clashdetection/suppressionrules/{id}

Gets the clash detection suppression rule details for the specified rule id.

Authentication

Requires Authorization header with valid Bearer token for scope itwin-platform.

For more documentation on authorization and how to get access token visit OAUTH2 Authorization page.

Request parameters

Name
In
Required?
Description
id
template
Yes

Rule id

Request headers

Name
Required?
Description
Include-User-Metadata
No

Optional. Include user metadata when true.

Authorization
Yes

OAuth access token with itwin-platform scope

Accept
Yes

Setting to application/vnd.bentley.itwin-platform.v1+json is recommended.

Response 200 OK

OK

json
{
    "suppressionRule": {
        "displayName": "ClashDetectionTest1",
        "reason": "Clash Detection Test",
        "creationDateTime": "2021-06-17T14:45:47.66Z",
        "modificationDateTime": "2021-06-24T14:49:59.66Z",
        "templateId": "ZuO3OCC8sUuVcgeXz1Ih_fFWlDoxH2FNmf0lWD6M8Dg",
        "parameters": "{\"propertyName\":\"Pitch\",\"lowerBound\":\"1\",\"upperBound\":\"2\"}",
        "_links": {
            "createdBy": {
                "href": "https://api.bentley.com/accesscontrol/itwins/38b7e366-bc20-4bb1-9572-0797cf5221fd/members/99cf5e21-735c-4598-99eb-fe3940f96353"
            },
            "lastModifiedBy": {
                "href": "https://api.bentley.com/accesscontrol/itwins/38b7e366-bc20-4bb1-9572-0797cf5221fd/members/99cf5e21-735c-4598-99eb-fe3940f96353"
            }
        },
        "userMetadata": {
            "createdBy": {
                "email": "John.Johnson@org.com",
                "name": "John Johnson"
            },
            "modifiedBy": {
                "email": "John.Johnson@org.com",
                "name": "John Johnson"
            }
        }
    }
}

Response 401 Unauthorized

This response indicates that request lacks valid authentication credentials. Access token might not been provided, issued by the wrong issuer, does not have required scopes or request headers were malformed.

json
{
    "error": {
        "code": "HeaderNotFound",
        "message": "Header Authorization was not found in the request. Access denied."
    }
}

Response 404 Not Found

This response indicates that the specified rule was not found.

json
{
    "error": {
        "code": "ClashDetectionSuppressionRuleNotFound",
        "message": "Requested suppression rule is not available."
    }
}

Response 429 Too many requests

This response indicates that the user has sent too many requests in a given amount of time.

json
{
    "error": {
        "code": "TooManyRequests",
        "message": "More requests were received than the subscription rate-limit allows."
    }
}

Response headers

Name
Description
retry-after

The number of requests exceeds the rate-limit for the client subscription.

Clash Detection Suppression Rule

TableSchema
Name
Type
Description
id
String

The id of the suppression rule.

displayName
String

The name of the suppression rule.

templateId
String

The template id of the suppression rule.

reason
String

The reason for the suppression rule.

parameters
String

The parameters for the suppression rule.

creationDateTime
Date-time

The date/time when the test was created.

modificationDateTime
Date-time

The date/time when the test was last modified.

_links

The links to get the related suppression rule response links.

Clash Detection Suppression Rule Links

TableSchema
Name
Type
Description
createdBy

The link to get user details of the user that created the suppression rule.

lastModifiedBy

The link to get user details of the user that last modified the suppression rule.

Link

Hyperlink container.

TableSchema
Name
Type
Description
href
String

Hyperlink container.

Error

Contains error information.

TableSchema
Name
Type
Description
code
String

One of a server-defined set of error codes.

message
String

A human-readable representation of the error.

target
String

The target of the error.

Error Response

Gives details for an error that occurred while handling the request. Note that clients MUST NOT assume that every failed request will produce an object of this schema, or that all of the properties in the response will be non-null, as the error may have prevented this response from being constructed.

TableSchema
Name
Type
Description
error

Error information.