Table of contents
Access Control
Download API definition:
POST https://api.bentley.com/accesscontrol/itwins/{id}/members

Add new iTwin members

Authentication

Requires Authorization header with valid Bearer token for scope itwins:modify.

For more documentation on authorization and how to get access token visit OAUTH2 Authorization page.

Authorization

User must have the administration_invite_member permission assigned at the iTwin level or be an Organization Administrator for the Organization that owns a given iTwin.

An Organization Administrator must have at least one of the following roles assigned in User Management: Account Administrator, Co-Administrator, or CONNECT Services Administrator. For more information about User Management please visit our Bentley Communities Licensing, Cloud, and Web Services wiki page.

Request parameters

Name
Required?
Description
id
Yes

The iTwin ID

Request headers

Name
Required?
Description
Authorization
Yes

OAuth access token with scope itwins:modify

Accept
No

Setting to application/vnd.bentley.itwin-platform.v1+json is recommended.

Request body

Members (add by email)

Name
Type
Required?
Description
members
No

List of members.

Example

json
{
    "members": [{
        "email": "John.Doe@bentley.com",
        "roleId": "5abbfcef-0eab-472a-b5f5-5c5a43df34b1"
    }]
}

Response 201 Created

iTwin member was successfully added.

Response 401 Unauthorized

This response indicates that request lacks valid authentication credentials. Access token might not been provided, issued by the wrong issuer, does not have required scopes or request headers were malformed.

json
{
    "error": {
        "code": "Unauthorized",
        "message": "Access denied due to invalid access_token. Make sure to provide a valid token for this API endpoint."
    }
}

Response 403 Forbidden

The user has insufficient permissions for the requested operation.

json
{
    "error": {
        "code": "InsufficientPermissions",
        "message": "The user has insufficient permissions for the requested operation."
    }
}

Response 404 Not Found

This response indicates that iTwin, email, or roles with specified ID were not found.

json
{
    "error": {
        "code": "ItwinNotFound",
        "message": "Requested iTwin is not available."
    }
}

Response 409 Conflict

Invalid request to add new iTwin member. Member already exists in iTwin.

json
{
    "error": {
        "code": "iTwinMemberAlreadyExists",
        "message": "Member '364332ad-2b18-4c72-a4a7-773075c6d30c' already exists in iTwin '1b7410a8-f273-48c7-8d6c-2689e8daeb75'."
    }
}

Response 422 Unprocessable Entity

Invalid request to add new iTwin member. Request payload might be missing some of the required properties.

json
{
    "error": {
        "code": "InvalidiTwinsMemberRequest",
        "message": "Request body or query is invalid.",
        "details": [{
                "code": "MissingRequiredProperty",
                "message": "Required property is missing.",
                "target": "members[0].email"
            },
            {
                "code": "MissingRequiredProperty",
                "message": "Required property is missing.",
                "target": "members[0].roleId"
            }
        ]
    }
}

Response 429 Too many requests

This response indicates that the user has sent too many requests in a given amount of time.

json
{
    "error": {
        "code": "TooManyRequests",
        "message": "More requests were received than the subscription rate-limit allows."
    }
}

Response headers

Name
Description
retry-after

The number of requests exceeds the rate-limit for the client subscription.

Member (add by email)

Name
Type
Description
email
String

User email.

roleId
String

Id of the role

Members (add by email)

Name
Type
Description
members

List of members.

Error

Contains error information and an optional array of more specific errors.

Name
Type
Description
code
String

One of a server-defined set of error codes.

message
String

A human-readable representation of the error.

target
String, null

The target of the error.

details
ErrorDetails[], null

Optional array of more specific errors.

Error Details

Contains error information.

Name
Type
Description
code
String

One of a server-defined set of error codes.

message
String

A human-readable representation of the error.

target
String, null

The target of the error.

Error Response

Gives details for an error that occurred while handling the request. Note that clients MUST NOT assume that every failed request will produce an object of this schema, or that all of the properties in the response will be non-null, as the error may have prevented this response from being constructed.

Name
Type
Description
error

Error information.