Table of contents
Property Validation
Download API definition:
This operation is deprecated. Please upgrade to the current version of this API as soon as possible.
GET https://api.bentley.com/validation/propertyValue/results/{id}

Gets the property value validation result details for the specified result id.

Authentication

Requires Authorization header with valid Bearer token for scope itwin-platform.

For more documentation on authorization and how to get access token visit OAUTH2 Authorization page.

Request parameters

Name
In
Required?
Description
id
template
Yes

Result id

Request headers

Name
Required?
Description
Authorization
Yes

OAuth access token with itwin-platform scope

Accept
Yes

Setting to application/vnd.bentley.itwin-platform.v1+json is recommended.

Response 200 OK

OK

json
{
    "result": [{
            "elementId": "0x20000000701",
            "elementLabel": "Pipe 6 1-SWS-0104",
            "ruleIndex": 1,
            "badValue": "4"
        },
        {
            "elementId": "0x200000011a7",
            "elementLabel": "Pipe 6 1-SWS-0107",
            "ruleIndex": 0,
            "badValue": "2"
        }
    ],
    "ruleList": [{
            "id": "ZuO3OCC8sUuVcgeXz1Ih_QE_7wcQ6WZIqE_IWb8geVc",
            "displayName": "Manufacturer name"
        },
        {
            "id": "ZuO3OCC8sUuVcgeXz1Ih_TsW5jCImyFKjomf_voaSbQ",
            "displayName": "Surface Rule Test"
        }
    ]
}

Response 401 Unauthorized

This response indicates that request lacks valid authentication credentials. Access token might not been provided, issued by the wrong issuer, does not have required scopes or request headers were malformed.

json
{
    "error": {
        "code": "HeaderNotFound",
        "message": "Header Authorization was not found in the request. Access denied."
    }
}

Response 404 Not Found

This response indicates that the specified result was not found.

json
{
    "error": {
        "code": "ValidationResultNotFound",
        "message": "Requested result is not available."
    }
}

Response 429 Too many requests

This response indicates that the user has sent too many requests in a given amount of time.

json
{
    "error": {
        "code": "TooManyRequests",
        "message": "More requests were received than the subscription rate-limit allows."
    }
}

Response headers

Name
Description
retry-after

The number of requests exceeds the rate-limit for the client subscription.

Property Value Result

TableSchema
Name
Type
Description
result

Array of all the failures in this property value validation result.

ruleList

Array of all the validation rule lookup entries.

Failure

The details for a property value validation failure.

TableSchema
Name
Type
Description
elementId
String

Unique identifier of the element.

elementLabel
String

The display label of the element.

ruleIndex
Integer

The zero-based index used to lookup the validation rule in the ruleList.

badValue
String

The invalid value that was found.

Rule Lookup Entry

TableSchema
Name
Type
Description
id
String

Unique identifier of the rule.

displayName
String

Display name of the rule.

Error

Contains error information.

TableSchema
Name
Type
Description
code
String

One of a server-defined set of error codes.

message
String

A human-readable representation of the error.

target
String

The target of the error.

Error Response

Gives details for an error that occurred while handling the request. Note that clients MUST NOT assume that every failed request will produce an object of this schema, or that all of the properties in the response will be non-null, as the error may have prevented this response from being constructed.

TableSchema
Name
Type
Description
error

Error information.