Projects

This API is deprecated. Please upgrade to the current version of this API as soon as possible.

Project Users

Download API definition:

GET https://api.bentley.com/projects/{id}/members[?$skip][&$top]

Retrieves a list of team members and their roles assigned to a specified project.

This API is being deprecated

This API is being superseded by the iTwins API and the Access Control API. Please consider transitioning your software to the iTwins API.

With any questions, please first consult the iTwins API FAQ. If your question isn't answered there, please use our Community Support Channels to contact our developers.

Authentication

Requires Authorization header with valid Bearer token for scope projects:read.

For more documentation on authorization and how to get access token visit OAUTH2 Authorization page.

Authorization

User must be an Organization Administrator for the Organization that owns a given project or be a project team member.

An Organization Administrator must have at least one of the following roles assigned in User Management: Account Administrator, Co-Administrator, or CONNECT Services Administrator. For more information about User Management please visit our Bentley Communities Licensing, Cloud, and Web Services wiki page.

Response

By default, each member in the returned list of members will only have names of the roles that are assigned to the user.

A full representation of roles assigned to the member can be returned by specifying the prefer header that includes a value of return=representation.

Request parameters

Name
In
Required?
Description
id
template
Yes

The project ID

$skip
query
No

The $skip query option requests the number of items in the queried collection that are to be skipped and not included in the result.

$top
query
No

The $top system query option requests the number of items in the queried collection to be included in the result. Value must be less or equal to 100.

Request headers

Name
Required?
Description
Authorization
Yes

OAuth access token with scope projects:read

Accept
No

Setting to application/vnd.bentley.itwin-platform.v1+json is recommended.

Response 200 OK

OK

json

Response 401 Unauthorized

This response indicates that request lacks valid authentication credentials. Access token might not been provided, issued by the wrong issuer, does not have required scopes or request headers were malformed.

json

Response 404 Not Found

This response indicates that project with specified ID was not found.

json

Response 422 Unprocessable Entity

Invalid request to get project team members.

json

Response 429 Too many requests

This response indicates that the user has sent too many requests in a given amount of time.

json

Response headers

Name
Description
retry-after

The number of requests exceeds the rate-limit for the client subscription.

Team Member (role names)

TableSchema
Name
Type
Description
userId
String

The user Id in Identity Management System.

email
String

User email.

givenName
String

User given name.

surname
String

User surname.

organization
String

Organization user is member of in Identity Management System.

roles
String[]

List of role names.

Team Member (full role representation)

TableSchema
Name
Type
Description
userId
String

The user Id in Identity Management System.

email
String

User email.

givenName
String

User given name.

surname
String

User surname.

organization
String

Organization user is member of in Identity Management System.

roles

List of roles.

Team Members (prefer return=minimal)

TableSchema
Name
Type
Description
members

List of team members.

_links

Team Members (prefer return=representation)

TableSchema
Name
Type
Description
members

List of team members.

_links

Role

TableSchema
Name
Type
Description
id
String

The role id.

displayName
String

The display name for the role.

description
String

The description for the role.

permissions
String[]

List of permissions assigned to the role.

Links

TableSchema
Name
Type
Description
next

Link

Hyperlink container.

TableSchema
Name
Type
Description
href
String

Hyperlink container.

Error

Contains error information and an optional array of more specific errors.

TableSchema
Name
Type
Description
code
String

One of a server-defined set of error codes.

message
String

A human-readable representation of the error.

target
String

The target of the error.

details

Optional array of more specific errors.

Error Details

Contains error information.

TableSchema
Name
Type
Description
code
String

One of a server-defined set of error codes.

message
String

A human-readable representation of the error.

target
String

The target of the error.

Error Response

Gives details for an error that occurred while handling the request. Note that clients MUST NOT assume that every failed request will produce an object of this schema, or that all of the properties in the response will be non-null, as the error may have prevented this response from being constructed.

TableSchema
Name
Type
Description
error

Error information.