Blueprint API Reference

Blueprint API Reference

Once your iTwin data is imported to Unreal using Datasmith, there are some convenience functions in the iTwin Unreal Datasmith Plugin that you can use to control and introspect the schedule animation.

struct Separated Export Scene Data

Global metadata accessible from scenes exported without the combine-meshes option.

Properties

Name
Type
Description
Schedule Ticks Per Frame
int64
The amount of FDateTime ticks that the schedule animates through in one 24FPS frame.
Schedule Ticks Per Second
int64
The amount of FDateTime ticks that the schedule animates through in a second of game time.
Schedule Start Date Time
The start date and time of the schedule animation.
Schedule End Date Time
The end date and time of the schedule animation.

class Scheduled Actor

The actor class that handles animating combined-mesh scenes.

Functions

 
Name
Return Type
Description
Get Combined Mesh Actor
Get the static mesh actor for the combined mesh from the actor hierarchy.
Format Date Time
Get an FString representing the given date as an HTTP date (See FString::HttpDate).
Get Separated Export Scene Data
Get the global scene metadata from a scene that was exported without mesh combination.
Get Schedule Date Time From Active Sequence
Get the global scene metadata from a scene that was exported without mesh combination.
Synchronize With Level Sequence
void
Synchronize the ScheduledActor's timing with the state of a level sequence. Make sure to have called CorrectLevelSequenceEnd first.
Correct Level Sequence End
void
Correct the length of a level sequence to fit that of a schedule animation in this AScheduleActor. This currently necessary due to a limitation of the Datasmith API.

Properties

Name
Type
Description
Animation Start Time
The start date and time of the schedule animation.
Animation End Time
The start date and time of the schedule animation.
Animation Time
The current date time of the animation, set this to update the animation.
Animation Ticks Per Second Scale
float
The amount of schedule datetime ticks to advance per second. Defaults to one week of schedule time per second of game time.
Animation Auto Replay
bool
Whether to restart the animation immediately at the start time upon reaching the end of the schedule animation.
Animation Is Playing
bool
Whether the animation is playing. Set this as false to pause the animation.