Table of contents
Webhooks
Download API definition:
GET https://api.bentley.com/webhooks/

Returns a list of user's owned webhooks of any event source.

Authentication

Requires Authorization header with valid Bearer token for scope webhooks:read.

For more documentation on authorization and how to get access token visit OAUTH2 Authorization page.

Request headers

Name
Required?
Description
Authorization
Yes

OAuth access token with scope webhooks:read

Accept
Yes

Setting to application/vnd.bentley.itwin-platform.v1+json is recommended.

Response 200 OK

OK

json
{
    "webhooks": [{
            "id": "b6db0467-52ae-4ff5-a9af-851c8e59a543",
            "eventSource": "iModels",
            "isActive": false,
            "isValidated": true,
            "callbackUrl": "https://some-event-callback.io/events",
            "expirationDateTime": "2021-06-07T09:15:41.9426079Z"
        },
        {
            "id": "418fd669-e256-46f4-a891-732e4c745044",
            "eventSource": "iModels",
            "isActive": true,
            "isValidated": true,
            "callbackUrl": "https://some-event-callback.io/events",
            "expirationDateTime": "2021-07-31T11:56:22.9562857Z"
        }
    ]
}

Response 401 Unauthorized

This response indicates that request lacks valid authentication credentials. Access token might not been provided, issued by the wrong issuer, does not have required scopes or request headers were malformed.

json
{
    "error": {
        "code": "HeaderNotFound",
        "message": "Header Authorization was not found in the request. Access denied."
    }
}

Response 429 Too many requests

This response indicates that the user has sent too many requests in a given amount of time.

json
{
    "error": {
        "code": "TooManyRequests",
        "message": "More requests were received than the subscription rate-limit allows."
    }
}

Response headers

Name
Description
retry-after

The number of requests exceeds the rate-limit for the client subscription.

Webhook

Common property representation of a webhook.

TableSchema
Name
Type
Description
id
String

Globally unique identifier of the webhook.

eventSource
String

Webhook events source name.

isActive
Boolean

An indicator showing webhook activity. If true, webhook is actively forwarding the events. If false, webhook events are stopped.

isValidated
Boolean

A value that indicates if webhook callback ownership is validated.

callbackUrl
String

URL where webhook events are sent.

expirationDateTime
String

Webhook expiration date and time.

Error

Contains error information.

TableSchema
Name
Type
Description
code
String

One of a server-defined set of error codes.

message
String

A human-readable representation of the error.

target
String

The target of the error.

Error Response

Gives details for an error that occurred while handling the request. Note that clients MUST NOT assume that every failed request will produce an object of this schema, or that all of the properties in the response will be non-null, as the error may have prevented this response from being constructed.

TableSchema
Name
Type
Description
error

Error information.