Table of contents
Property Validation

Property Value Tests

Download API definition:

GET https://api.bentley.com/validation/propertyValue/tests/{id}

Gets the property value validation test details for the specified test id.

Authentication

Requires Authorization header with valid Bearer token for scope validation:read.

For more documentation on authorization and how to get access token visit OAUTH2 Authorization page.

Request parameters

Name
In
Required?
Description
id
template
Yes

Test id

Request headers

Name
Required?
Description
Include-User-Metadata
No

Optional. Include user metadata when true.

Authorization
Yes

OAuth access token with scope validation:read

Accept
Yes

Setting to application/vnd.bentley.itwin-platform.v1+json is recommended.

Response 200 OK

OK

json
{
    "test": {
        "displayName": "PV test1",
        "description": "PV test1",
        "creationDateTime": "2021-06-24T14:41:47.073Z",
        "modificationDateTime": "2021-06-24T14:41:47.073Z",
        "rules": [
            "ZuO3OCC8sUuVcgeXz1Ih_QE_7wcQ6WZIqE_IWb8geVc"
        ],
        "stopExecutionOnFailure": true,
        "_links": {
            "createdBy": {
                "href": "https://api.bentley.com/projects/38b7e366-bc20-4bb1-9572-0797cf5221fd/members/99cf5e21-735c-4598-99eb-fe3940f96353"
            },
            "lastModifiedBy": {
                "href": "https://api.bentley.com/projects/38b7e366-bc20-4bb1-9572-0797cf5221fd/members/99cf5e21-735c-4598-99eb-fe3940f96353"
            }
        },
        "userMetadata": {
            "createdBy": {
                "email": "John.Johnson@org.com",
                "name": "John Johnson"
            },
            "modifiedBy": {
                "email": "John.Johnson@org.com",
                "name": "John Johnson"
            }
        }
    }
}

Response 401 Unauthorized

This response indicates that request lacks valid authentication credentials. Access token might not been provided, issued by the wrong issuer, does not have required scopes or request headers were malformed.

json
{
    "error": {
        "code": "HeaderNotFound",
        "message": "Header Authorization was not found in the request. Access denied."
    }
}

Response 404 Not Found

This response indicates that the specified test was not found.

json
{
    "error": {
        "code": "ValidationTestNotFound",
        "message": "Requested test is not available."
    }
}

Response 429 Too many requests

This response indicates that the user has sent too many requests in a given amount of time.

json
{
    "error": {
        "code": "TooManyRequests",
        "message": "More requests were received than the subscription rate-limit allows."
    }
}

Response headers

Name
Description
retry-after

The number of requests exceeds the rate-limit for the client subscription.

Property Value Test

TableSchema
Name
Type
Description
displayName
String

The display name of the test.

description
String

The description of the test.

creationDateTime
Date-time

The date/time when the rule was created.

modificationDateTime
Date-time

The date/time when the rule was last modified.

rules
String[]
stopExecutionOnFailure
Boolean

The flag to stop execution on failure.

_links

The links to get the user details.

Property Value Test User Links

TableSchema
Name
Type
Description
createdBy

The link to get user details of the user that created the test.

lastModifiedBy

The link to get user details of the user that last modified the test.

Link

Hyperlink container.

TableSchema
Name
Type
Description
href
String

Hyperlink container.

Error

Contains error information.

TableSchema
Name
Type
Description
code
String

One of a server-defined set of error codes.

message
String

A human-readable representation of the error.

target
String

The target of the error.

Error Response

Gives details for an error that occurred while handling the request. Note that clients MUST NOT assume that every failed request will produce an object of this schema, or that all of the properties in the response will be non-null, as the error may have prevented this response from being constructed.

TableSchema
Name
Type
Description
error

Error information.