Table of contents
Property Validation
Download API definition:
This operation is deprecated. Please upgrade to the current version of this API as soon as possible.
GET https://api.bentley.com/validation/propertyValue/runs/{id}

Retrieves details of a validation run for the run specified by the run id.

  • Links are included to retrieve the associated test and result. The run status in the response can be polled periodically as the agent job completes asynchronously. Calling the link to get the result before the run status is 'completed' will return a 202 response.

  • Discover run ids by calling GET /validation/propertyValue/runs

Authentication

Requires Authorization header with valid Bearer token for scope itwin-platform.

For more documentation on authorization and how to get access token visit OAUTH2 Authorization page.

Request parameters

Name
In
Required?
Description
id
template
Yes

Run id

Request headers

Name
Required?
Description
Authorization
Yes

OAuth access token with itwin-platform scope

Accept
Yes

Setting to application/vnd.bentley.itwin-platform.v1+json is recommended.

Response 200 OK

OK

json
{
    "run": {
        "id": "1cKcvg7Ky0e66uT-2u8vpSTBs9cXiSlMrE8Zym2jD0Y",
        "displayName": "PropertyValueTest1 2021-06-17 14:45:47Z",
        "executedDateTime": "2021-06-17T14:45:47.073Z",
        "count": "27",
        "userName": "John Johnson",
        "status": "queued",
        "resultId": "1cKcvg7Ky0e66uT-2u8vpU1fL3jpQOxEs7jYnNkoTYgKU2BJP-MPTK5-8S9ARz4T",
        "_links": {
            "result": {
                "href": "https://api.bentley.com/validation/propertyValue/results/1cKcvg7Ky0e66uT-2u8vpU1fL3jpQOxEs7jYnNkoTYgKU2BJP-MPTK5-8S9ARz4T"
            },
            "test": {
                "href": "https://api.bentley.com/validation/propertyValue/tests/1cKcvg7Ky0e66uT-2u8vpQlT8rXn5qlIq7JOBnNZtKY"
            }
        }
    }
}

Response 401 Unauthorized

This response indicates that request lacks valid authentication credentials. Access token might not been provided, issued by the wrong issuer, does not have required scopes or request headers were malformed.

json
{
    "error": {
        "code": "HeaderNotFound",
        "message": "Header Authorization was not found in the request. Access denied."
    }
}

Response 404 Not Found

This response indicates that the specified run was not found.

json
{
    "error": {
        "code": "ValidationRunNotFound",
        "message": "Requested run is not available."
    }
}

Response 429 Too many requests

This response indicates that the user has sent too many requests in a given amount of time.

json
{
    "error": {
        "code": "TooManyRequests",
        "message": "More requests were received than the subscription rate-limit allows."
    }
}

Response headers

Name
Description
retry-after

The number of requests exceeds the rate-limit for the client subscription.

Property Value Run

Run metadata

TableSchema
Name
Type
Description
id
String

Run id.

displayName
String

The display name of the run is the test name and execution date/time.

executedDateTime
Date-time

The date/time when the test was executed.

count
String

The number of issues found.

userName
String

The name of the user that started the run.

status
String

The status of the validation run. One of 'queued', 'started', 'completed', 'failed', 'downloadingIModel', 'storingResults', 'inProgress', 'completedToLimit', 'cancelled'

resultId
String

Result id.

_links

The links to get the result and test details.

Property Value Run Links

TableSchema
Name
Type
Description
result

The link to get the result details.

test

The link to get the test details.

Link

Hyperlink container.

TableSchema
Name
Type
Description
href
String

Hyperlink container.

Error

Contains error information.

TableSchema
Name
Type
Description
code
String

One of a server-defined set of error codes.

message
String

A human-readable representation of the error.

target
String

The target of the error.

Error Response

Gives details for an error that occurred while handling the request. Note that clients MUST NOT assume that every failed request will produce an object of this schema, or that all of the properties in the response will be non-null, as the error may have prevented this response from being constructed.

TableSchema
Name
Type
Description
error

Error information.