Table of contents
Property Validation
Download API definition:
This operation is deprecated. Please upgrade to the current version of this API as soon as possible.
GET https://api.bentley.com/validation/propertyValue/properties/imodels/{id}?projectId&filter

Gets the properties matching a filter string for the latest named version of an iModel. This request relies on a previous call to start schema extraction on an agent. Since this extraction completes asynchronously, the user can send this request periodically until a status of 'available' is returned in the response.

Authentication

Requires Authorization header with valid Bearer token for scope itwin-platform.

For more documentation on authorization and how to get access token visit OAUTH2 Authorization page.

Request parameters

Name
In
Required?
Description
id
template
Yes

iModel id

projectId
query
Yes

The id of the project containing the iModel from which to retrieve the properties info.

filter
query
Yes

The filter string to search for properties.

Request headers

Name
Required?
Description
Authorization
Yes

OAuth access token with itwin-platform scope

Accept
Yes

Setting to application/vnd.bentley.itwin-platform.v1+json is recommended.

Response 200 OK

OK

json
{
    "status": "available",
    "data": {
        "searchProperty": {
            "schemas": [{
                "name": "Architecture_rvt_ThreeD_3D",
                "label": null,
                "entities": [{
                        "name": "Cameras",
                        "label": null,
                        "properties": [{
                                "name": "Eye__x0020__Elevation_PG_VIEW_CAMERA_Length",
                                "label": "Eye Elevation"
                            },
                            {
                                "name": "Far__x0020__Clip__x0020__Offset_PG_VIEW_EXTENTS_Length",
                                "label": "Far Clip Offset"
                            },
                            {
                                "name": "Target__x0020__Elevation_PG_VIEW_CAMERA_Length",
                                "label": "Target Elevation"
                            }
                        ]
                    },
                    {
                        "name": "Casework",
                        "label": null,
                        "properties": [{
                                "name": "Depth_PG_GEOMETRY_Length_TYPE",
                                "label": "Depth"
                            },
                            {
                                "name": "Counter__x0020__Thickness_PG_GEOMETRY_Length_TYPE",
                                "label": "Counter Thickness"
                            },
                            {
                                "name": "Width_PG_GEOMETRY_Length_TYPE",
                                "label": "Width"
                            },
                            {
                                "name": "Height_PG_GEOMETRY_Length_TYPE",
                                "label": "Height"
                            },
                            {
                                "name": "Offset_PG_CONSTRAINTS_Length",
                                "label": "Offset"
                            },
                            {
                                "name": "Sink__x0020__Opening__x0020__Depth_PG_GEOMETRY_Length",
                                "label": "Sink Opening Depth"
                            },
                            {
                                "name": "Sink__x0020__Location_PG_GEOMETRY_Length",
                                "label": "Sink Location"
                            },
                            {
                                "name": "Sink__x0020__Location__x0020__To__x0020__Wall_PG_GEOMETRY_Length",
                                "label": "Sink Location To Wall"
                            },
                            {
                                "name": "Length_PG_GEOMETRY_Length",
                                "label": "Length"
                            },
                            {
                                "name": "Sink__x0020__Opening__x0020__Width_PG_GEOMETRY_Length",
                                "label": "Sink Opening Width"
                            },
                            {
                                "name": "Toe__x0020__Depth_PG_GEOMETRY_Length_TYPE",
                                "label": "Toe Depth"
                            },
                            {
                                "name": "Toe__x0020__Height_PG_GEOMETRY_Length_TYPE",
                                "label": "Toe Height"
                            }
                        ]
                    }
                ]
            }]
        }
    }
}

Response 401 Unauthorized

This response indicates that request lacks valid authentication credentials. Access token might not been provided, issued by the wrong issuer, does not have required scopes or request headers were malformed.

json
{
    "error": {
        "code": "HeaderNotFound",
        "message": "Header Authorization was not found in the request. Access denied."
    }
}

Response 404 Not Found

This response indicates that the specified iModel or project was not found.

json
{
    "error": {
        "code": "iModelNotFound",
        "message": "Requested iModel is not available."
    }
}

Response 422 Unprocessable Entity

The 422 (Unprocessable Entity) status code indicates that the request cannot be processed by the server due to a client error (e.g. malformed request syntax)

json
{
    "error": {
        "code": "InvalidValidationRequest",
        "message": "Filter must be provided."
    }
}

Response 429 Too many requests

This response indicates that the user has sent too many requests in a given amount of time.

json
{
    "error": {
        "code": "TooManyRequests",
        "message": "More requests were received than the subscription rate-limit allows."
    }
}

Response headers

Name
Description
retry-after

The number of requests exceeds the rate-limit for the client subscription.

properties-info

Properties info

TableSchema
Name
Type
Description
status
String

The status of the properties info. One of 'available', 'unavailable'

searchProperty

Properties information.

Search Property

Properties info

TableSchema
Name
Type
Description
schemas

The schema.

Schema

Schema info

TableSchema
Name
Type
Description
name
String

The name of the schema.

label
String,null

The label of the schema.

entities

An array of entities in the schema.

Entity Class

Entity Class info

TableSchema
Name
Type
Description
name
String

The name of the class.

label
String,null

The label of the class.

properties

An array of properties in the class.

aspects

An array of aspect properties of the class.

typeDefinitions

An array of type definitions properties of the class.

Property

Property info

TableSchema
Name
Type
Description
name
String

The name of the property.

label
String,null

The label of the property.

Error

Contains error information.

TableSchema
Name
Type
Description
code
String

One of a server-defined set of error codes.

message
String

A human-readable representation of the error.

target
String

The target of the error.

Error Response

Gives details for an error that occurred while handling the request. Note that clients MUST NOT assume that every failed request will produce an object of this schema, or that all of the properties in the response will be non-null, as the error may have prevented this response from being constructed.

TableSchema
Name
Type
Description
error

Error information.